Pet not using focus?

Anything related to Hunter pets.
Forum rules
Treat others with respect. Report, don't respond. Read the complete forum rules.
Kipper
Posts: 3
Joined: Sat Jan 16, 2010 1:01 pm
Realm: Dragonblight

Pet not using focus?

Unread post by Kipper » Sat Jan 16, 2010 1:29 pm

Hello everyone! I've been using Petopia for a while now, but this is my first time ever communicating with anyone. :)

Anyway, I've been having this problem and after searching around the internet, it seems like I'm either the only one who has this problem, or it's something so easily fixable that nobody's bothered to say anything and I'm just that thick. :x

So on my Tauren Hunter, I have this eagle. I thought they looked rather cool next to a Tauren so I decided to go tame one, even though I'm not exactly a big fan of Cunning pets (if they would just turn carrion feeder into something more useful I'd probably like them more). I'm currently trying to get him to level 80, but I've run into what seems to be a glitch of some sort.

See, roughly 50% of the time I send him to attack something, he refuses to use any skills and just auto-attacks the enemy. He won't use growl, claw, ect. unless I manually tell him to (although during the middle of a fight he sometimes decides to use his special attacks). After a while I got tired of managing both my attacks and his and fighting off everything because I instantly grab all the aggro, so he's currently sitting in my stables at level 78 until I figure this out.

I haven't done much testing, but my other pets (two cats and a crab) are doing perfectly fine with their focus. I did some stuff with my NE Hunter, and while her chimera used focus without any problems, her owl ended up doing the same thing as my eagle.

So is this just a glitch with Birds of Prey? It doesn't seem to be the entire Cunning family (at least not chimeras). Or am I just doing something obviously wrong? :/


(Also if this has been addressed before and answered, then my apologies. I couldn't find anything about this anywhere.)

Ryno
Guild Master
Guild Master
Posts: 3485
Joined: Tue Jan 05, 2010 2:38 pm
Realm: US Grizzly Hills, Deathwing, Wyrmrest Accord
Gender: Wink wink.
Location: Wandering aimlessly under the effect of the Curse of Burgy BlackheaLET'S BUCKLE SOME SWASH!!
Contact:

Re: Pet not using focus?

Unread post by Ryno » Sat Jan 16, 2010 1:32 pm

Hmm, only thing I can think of that might do this is that you have the autocast turned off on that pet. Other than that, it just might be a glitch with that particular pet. What I would do it:

Open pet spellbook (Shift + I) and make sure all spells are turned on autocast (flashy around the picture of the spell).

If it's still not working, consider taming the same pet again, and seeing if you see the same problem.

Image


Kipper
Posts: 3
Joined: Sat Jan 16, 2010 1:01 pm
Realm: Dragonblight

Re: Pet not using focus?

Unread post by Kipper » Sat Jan 16, 2010 2:04 pm

Hrm, now this is interesting.

Went back and killed some stuff with him, making sure everything except cower was on autocast (mostly because of old habbit. But I didn't need it anyway), and he still didn't use focus some of the time. Went over to Grizzly Hills, tamed another eagle (same species and everything), then went and killed stuff with him. Surprisingly, he actually used focus every time.

But then I noticed that I had forgotten to set his talent points, so I made it the same as my other eagle, and sure enough, now he isn't using focus all the time.

I'm beginning to suspect that it has something to do with his talent points, but I have no idea where to look. Guess like I'll have to experiment a little more. :/ Although that could explain why it isn't happening with my Ferocity or Tenacity pets.

User avatar
Vephriel
Illustrious Master Hunter
Illustrious Master Hunter
Posts: 16009
Joined: Wed Jan 06, 2010 8:07 pm
Realm: Wyrmrest Accord US
Gender: Female
Location: Alberta, Canada

Re: Pet not using focus?

Unread post by Vephriel » Sat Jan 16, 2010 3:12 pm

Hmm, sounds like a definite glitch. =/ Might want to report it to a GM just in case.

User avatar
VelkynKarma
Grand Master Hunter
Grand Master Hunter
Posts: 2496
Joined: Sat Jan 09, 2010 2:40 pm
Realm: Quel'Dorei, Nessingwary
Location: Saturo's necromancy class. Karma = World's Worst Necromancer.

Re: Pet not using focus?

Unread post by VelkynKarma » Sat Jan 16, 2010 6:21 pm

That's weird. But you said your other Cunning pets still attack fine, and use their focus? If that's the case, it wouldn't be the talent points that are the problem in and of itself..would it? It might have something to do with the pet itself, plus the talent points.

Well, good luck figuring it out either way!

~VelkynKarma

Image

Silinrul and Jiaphyon of <Ominous Latin Name>


A big thanks to Vephriel for the awesome signature :)

Help my Dragons


User avatar
Tahlian
Master Hunter
Master Hunter
Posts: 1090
Joined: Tue Jan 05, 2010 1:49 am
Realm: Feathermoon

Re: Pet not using focus?

Unread post by Tahlian » Sat Jan 16, 2010 6:51 pm

Do you have this talent chosen and fully maxed out on your Bird of Prey?

Owl's Focus

2 ranks

Your pet has a [15%/30%] chance after using an ability that the next ability will cost no Focus if used within 8 sec.


It's possible that what's actually happening is that this Cunning family ability is proccing very often, as you say sometimes your pet uses focus and sometimes he doesn't. If he does have this ability, you can take him out and kill things with him, watching the combat log to see when Owl's Focus goes off, and what ability he uses after it goes off. It could be that he really is using his abilities...but because of Owl's Focus proccing, they aren't costing any focus for him to use.

Here there be dragons... http://dragcave.net/user/Tahlian

And here there be more dragons, too...http://flightrising.com/main.php?p=lair&id=22415


Kipper
Posts: 3
Joined: Sat Jan 16, 2010 1:01 pm
Realm: Dragonblight

Re: Pet not using focus?

Unread post by Kipper » Sat Jan 16, 2010 7:28 pm

Well, I think I finally found the culprit. Wolverine Bite might be bugged. :/

It's like my pet won't use any focus until WB is active (as in, when he lands a critical hit), then after he uses it everything is fine. But it's weird because like I said sometimes it's fine and sometimes I have to turn it off autocast. Also, it doesn't seem to matter what other talent points I put in, it still happens if WB is on autocast. :x

Still kinda strange though because I thought WB was really popular for Cunnning pets, so you'd think that I would see someone else having trouble with this. I'm pretty sure that it is a bug though so I'll probably go report it soon.

Anyway thanks for all the advice guys, I really had no idea where to start looking for this problem. :D

Ryno
Guild Master
Guild Master
Posts: 3485
Joined: Tue Jan 05, 2010 2:38 pm
Realm: US Grizzly Hills, Deathwing, Wyrmrest Accord
Gender: Wink wink.
Location: Wandering aimlessly under the effect of the Curse of Burgy BlackheaLET'S BUCKLE SOME SWASH!!
Contact:

Re: Pet not using focus?

Unread post by Ryno » Sun Jan 17, 2010 8:52 pm

Kipper wrote:Well, I think I finally found the culprit. Wolverine Bite might be bugged. :/
So you went and spec'd him without Wolverine Bite, and tried him? Just asking for completion's sake, hehe.

Image


Post Reply